Maintenance work - KrämerIT telephone system
Scheduled for July 19, 2025 at 11:00 AM – 3:00 PM
Affects
Krämer IT Solutions
Under maintenance from 11:00 AM to 3:00 PM
Telefonanlage
Under maintenance from 11:00 AM to 3:00 PM
Completed
July 19, 2025 at 3:00 PMCompleted
July 19, 2025 at 3:00 PMMaintenance has completed successfully
In progress
July 19, 2025 at 11:00 AMIn progress
July 19, 2025 at 11:00 AMMaintenance is now in progress
Planned
July 19, 2025 at 11:00 AMPlanned
July 19, 2025 at 11:00 AMTo further improve the performance and stability of our administration services, we perform maintenance work.
During this time there may be temporary outages, please try again after about 10 minutes.
Thank you for your understanding.